OSPF: Virtual Links – Part II
· In the previous post OSPF: Virtual Links - Part I, we have seen how to create Virtual Links in case of an Area not connected to Area 0.
· In this post, let me take the case of partitioned Backbone area to create Virtual Links.
· Topology:
· R1-R2 link is part of Area 0
· R2-R3 link is part of Area 23
· R2 is an ABR for Area0 & Area 23
· R3-R4 link is part of Area 0
· R1’s loopback 1.1.1.1/32 is advertised into Area 0
· R2’s loopback 2.2.2.2/32 is advertised into Area 0
· R3’s loopback 3.3.3.3/32 is advertised into Area 23
· R4’s loopback 4.4.4.4/32 is advertised into Area 0
· Let’s see what happens before creating virtual link
R1#show run | begin router ospf
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 100.1.12.1 0.0.0.0 area 0
!
R2#show run | begin router ospf
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 100.1.12.2 0.0.0.0 area 0
network 100.1.23.2 0.0.0.0 area 23
!
R3#show run | begin router ospf
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 23
network 100.1.23.3 0.0.0.0 area 23
network 100.1.34.3 0.0.0.0 area 0
!
R4#show run | begin router ospf
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 100.1.34.4 0.0.0.0 area 0
!
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:30 100.1.12.2 Serial1/0
R1#
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:00:32 100.1.12.1 Serial1/0
3.3.3.3 0 FULL/ - 00:00:33 100.1.23.3 Serial1/1
R2#
R3#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 0 FULL/ - 00:00:35 100.1.34.4 Serial1/0
2.2.2.2 0 FULL/ - 00:00:39 100.1.23.2 Serial1/1
R3#
R4#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ - 00:00:37 100.1.34.3 Serial1/0
R4#
Observations:
· OSPF has been configured as per the Topology.
· All neighbors are up.
Let’s see the OSPF routing tables:
R1#show ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 100.1.12.2, 00:09:16, Serial1/0
100.0.0.0/24 is subnetted, 2 subnets
O IA 100.1.23.0 [110/128] via 100.1.12.2, 00:09:16, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/129] via 100.1.12.2, 00:09:16, Serial1/0
R1#
R1#
R2#show ip route ospf
R2#show ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 100.1.12.1, 00:09:22, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 100.1.23.3, 00:08:53, Serial1/1
R2#
R3#show ip route ospf
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/65] via 100.1.34.4, 00:08:38, Serial1/0
R3#
R4#show ip route ospf
100.0.0.0/24 is subnetted, 2 subnets
O IA 100.1.23.0 [110/128] via 100.1.34.3, 00:08:37, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/65] via 100.1.34.3, 00:08:37, Serial1/0
R4#
R4#
R2#show ip ospf database
R2#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 1297 0x80000004 0x000494 3
2.2.2.2 2.2.2.2 548 0x80000002 0x00C8EB 4
3.3.3.3 3.3.3.3 1 (DNA) 0x80000003 0x002569 3
4.4.4.4 4.4.4.4 704 (DNA) 0x80000002 0x00E55D 3
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
3.3.3.3 2.2.2.2 1292 0x80000001 0x004F98
3.3.3.3 3.3.3.3 720 (DNA) 0x80000001 0x00AE75
100.1.23.0 2.2.2.2 1292 0x80000001 0x00ACCB
100.1.23.0 3.3.3.3 720 (DNA) 0x80000001 0x008EE5
Router Link States (Area 23)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 548 0x80000002 0x003255 2
3.3.3.3 3.3.3.3 549 0x80000005 0x001151 3
Summary Net Link States (Area 23)
Link ID ADV Router Age Seq# Checksum
1.1.1.1 2.2.2.2 1294 0x80000001 0x00AB44
2.2.2.2 2.2.2.2 1294 0x80000001 0x00FA31
4.4.4.4 3.3.3.3 1250 0x80000001 0x0003DC
100.1.12.0 2.2.2.2 1294 0x80000001 0x00265D
100.1.34.0 3.3.3.3 1267 0x80000001 0x001554
R2#
R3#show ip ospf database
OSPF Router with ID (3.3.3.3) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 749 (DNA) 0x80000004 0x000494 3
2.2.2.2 2.2.2.2 1 (DNA) 0x80000002 0x00C8EB 4
3.3.3.3 3.3.3.3 1474 0x80000003 0x002569 3
4.4.4.4 4.4.4.4 326 0x80000003 0x00E35E 3
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
3.3.3.3 2.2.2.2 744 (DNA) 0x80000001 0x004F98
3.3.3.3 3.3.3.3 325 0x80000002 0x00AC76
100.1.23.0 2.2.2.2 744 (DNA) 0x80000001 0x00ACCB
100.1.23.0 3.3.3.3 325 0x80000002 0x008CE6
Router Link States (Area 23)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 1475 0x80000002 0x003255 2
3.3.3.3 3.3.3.3 1474 0x80000005 0x001151 3
Summary Net Link States (Area 23)
Link ID ADV Router Age Seq# Checksum
1.1.1.1 2.2.2.2 315 0x80000002 0x00A945
2.2.2.2 2.2.2.2 315 0x80000002 0x00F832
4.4.4.4 3.3.3.3 326 0x80000002 0x0001DD
100.1.12.0 2.2.2.2 315 0x80000002 0x00245E
100.1.34.0 3.3.3.3 326 0x80000002 0x001355
R3#
Observations:
· R1 and R2 don’t have R3-R4 link(100.1.34.0/24, which is part of another Area 0) in OSPF routing table
· R1 and R2 don’t have R4’s loopback(4.4.4.4/32, which is part of another Area 0) in OPSF routing table.
o This is because, R2(which is an ABR for Area 0 and 23), has not installed the routes received by R3, in its OSPF table). This is because; it has full-neighbor relationship in Area 0 (with R1).
o We can find in these prefixes in R2’s OSPF database, but it will not install them in its OSPF routing table.
o This is inbuilt inter-area loop prevention mechanism in OSPF.
· R3 and R4 don’t have R1-R2 link (100.1.12.0/24, which is part of another Area 0) in OSPF routing table.
· R3 and R4 don’t have R1’s loopback 1.1.1.1/32, which is part of another Area 0) in OSPF routing table.
· R3 and R4 don’t have r2’s loopback 2.2.2.2/32, which is part of another Area 0) in OSPF routing table.
o This is because, R3(which is an ABR for Area 0 and 23), has not installed the routes received by R2, in its OSPF table). This is because; it has full-neighbor relationship in Area 0 (with R4).
o We can find in these prefixes in R3’s OSPF database, but it will not install them in its OSPF routing table.
o This is inbuilt inter-area loop prevention mechanism in OSPF.
Solution: Create a Virtual-link through Area 23 (between R2 and R3) to connect the partitioned Area 0:
R2(config)#router ospf 1
R2(config-router)#
R2(config-router)#area 23 virtual-link 3.3.3.3
R2(config-router)#
*Jul 8 15:44:20.611: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on OSPF_VL0 from LOADING to FULL, Loading Done
R2(config-router)#
R3(config)#router ospf 1
R3(config-router)#area 23 virtual-link 2.2.2.2
R3(config-router)#
*Jul 8 15:44:20.767: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on OSPF_VL0 from LOADING to FULL, Loading Done
R3(config-router)#
R2#show ip ospf virtual-links
Virtual Link OSPF_VL0 to router 3.3.3.3 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 23, via interface Serial1/1, Cost of using 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Adjacency State FULL (Hello suppressed)
Index 2/3, retransmission queue length 0, number of retransmission 0
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec
R2#
R3#show ip ospf virtual-links
Virtual Link OSPF_VL0 to router 2.2.2.2 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 23, via interface Serial1/1, Cost of using 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:00
Adjacency State FULL (Hello suppressed)
Index 2/3, retransmission queue length 0, number of retransmission 0
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec
R3#
R1#show ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 100.1.12.2, 00:01:22, Serial1/0
100.0.0.0/24 is subnetted, 3 subnets
O 100.1.34.0 [110/192] via 100.1.12.2, 00:01:22, Serial1/0
O IA 100.1.23.0 [110/128] via 100.1.12.2, 00:01:22, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/129] via 100.1.12.2, 00:01:22, Serial1/0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/193] via 100.1.12.2, 00:01:22, Serial1/0
R1#
R1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/85/164 ms
R1#
R2#show ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 100.1.12.1, 00:02:42, Serial1/0
100.0.0.0/24 is subnetted, 3 subnets
O 100.1.34.0 [110/128] via 100.1.23.3, 00:02:42, Serial1/1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 100.1.23.3, 00:02:42, Serial1/1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/129] via 100.1.23.3, 00:02:42, Serial1/1
R2#
R3#show ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/129] via 100.1.23.2, 00:02:44, Serial1/1
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 100.1.23.2, 00:02:44, Serial1/1
100.0.0.0/24 is subnetted, 3 subnets
O 100.1.12.0 [110/128] via 100.1.23.2, 00:02:44, Serial1/1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/65] via 100.1.34.4, 00:02:44, Serial1/0
R3#
R4#show ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/193] via 100.1.34.3, 00:02:45, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/129] via 100.1.34.3, 00:02:45, Serial1/0
100.0.0.0/24 is subnetted, 3 subnets
O 100.1.12.0 [110/192] via 100.1.34.3, 00:02:45, Serial1/0
O IA 100.1.23.0 [110/128] via 100.1.34.3, 00:02:45, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/65] via 100.1.34.3, 00:02:45, Serial1/0
R4#
R4#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/95/152 ms
R4#
Observation:
· I have successfully repaired the problem in OSPF partitioned Area 0
No comments:
Post a Comment