Saturday 1 September 2012

CE-PE Routing: Configuring using RIP


CE-PE Routing: Configuring using RIP
·         There are many options for CE-PE routing.
·         In this post, let me configure routing between CE-PE using protocol RIP

·         In PE router, we need to enable the CE-PE link under “address-family ipv4 vrf VPN_A” in RIP.
·         In CE router, we need to enable the CE-PE link normally in RIP.

Let me take a basic topology to configure this:



VRF Configuration:

PE1(config-vrf)#rd 100:1
PE1(config-vrf)#route-target both 100:1
PE1(config-vrf)#do show run intser1/0
Building configuration...

Current configuration : 87 bytes
!
interfaceSerial1/0
ip address 10.1.13.3 255.255.255.0
serial restart-delay 0
end

PE1(config-vrf)#intser1/0
PE1(config-if)#ipvrf forwarding VPN_A
% Interface Serial1/0 IP address 10.1.13.3 removed due to enabling VRFVPN_A
PE1(config-if)#ip address 10.1.13.3 255.255.255.0
PE1(config-if)#do ping vrfVPN_A 10.1.13.1

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 10.1.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/17/44 ms
PE1(config-if)#

CE1:

CE1(config-if)#do show run intser1/0
Building configuration...

Current configuration : 87 bytes
!
interfaceSerial1/0
ip address 10.1.13.1 255.255.255.0
serial restart-delay 0
end

CE1(config-if)#do ping 10.1.13.3

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 10.1.13.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/25/44 ms
CE1(config-if)#

Observation:
·         CE1-PE1 link is up

PE1:

PE2(config-router-af)#ipvrfVPN_A
PE2(config-vrf)#rd 100:1
PE2(config-vrf)#route-target both 100:1
PE2(config-vrf)#do show run intser1/0
Building configuration...

Current configuration : 87 bytes
!
interfaceSerial1/0
ip address 10.1.24.4 255.255.255.0
serial restart-delay 0
end

PE2(config-vrf)#intser1/0
PE2(config-if)#do show run intser1/0
Building configuration...

Current configuration : 87 bytes
!
interfaceSerial1/0
ip address 10.1.24.4 255.255.255.0
serial restart-delay 0
end

PE2(config-if)#ipvrf forwarding VPN_A
% Interface Serial1/0 IP address 10.1.24.4 removed due to enabling VRFVPN_A
PE2(config-if)#ip address 10.1.24.4 255.255.255.0
PE2(config-if)#do ping vrfVPN_A 10.1.24.2

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 10.1.24.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/36 ms
PE2(config-if)#

CE2:

CE2(config-if)#do show run intser1/0
Building configuration...

Current configuration : 87 bytes
!
interfaceSerial1/0
ip address 10.1.24.2 255.255.255.0
serial restart-delay 0
end

CE2(config-if)#do ping 10.1.24.4

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 10.1.24.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/64 ms
CE2(config-if)#

Observation:
·         CE2-PE2 link is up

IGP-OSPF Configuration between PE1-PE2:

PE1(config-if)#do show run | begin router ospf
routerospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 100.1.34.3 0.0.0.0 area 0
!
PE2(config-if)#do show run | begin router ospf
routerospf 1
router-id 4.4.4.4
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 100.1.34.4 0.0.0.0 area 0
!

MP-iBGP configuration between PE1-PE2:

PE1(config)#do show run | begin router bgp
routerbgp 100
bgp router-id 3.3.3.3
nobgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
 !
address-familyvpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
 !
address-familyipv4vrfVPN_A
redistribute connected
redistribute static
no synchronization
exit-address-family
!

PE2(config-router-af)#do show run | begin router bgp
routerbgp 100
bgp router-id 4.4.4.4
nobgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
 !
address-familyvpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
 !
address-familyipv4vrfVPN_A
redistribute connected
redistribute static
no synchronization
exit-address-family
!

Configuring MPLS in the Core (between PE1-PE2):

PE1(config)#intser1/1
PE1(config-if)#mplsip
PE1(config-if)#

PE2(config)#intser1/1
PE2(config-if)#mplsip
PE2(config-if)#

Configuring RIP between CE1-PE1:

CE1(config)#router rip
CE1(config-router)#version 2
CE1(config-router)#no auto summary
                           ^
% Invalid input detected at '^' marker.

CE1(config-router)#no auto-summary
CE1(config-router)#network 10.1.13.0
CE1(config-router)#network 1.1.1.0
CE1(config-router)#network 11.11.11.0
CE1(config-router)#

PE1(config)#router rip
PE1(config-router)#version 2
PE1(config-router)#no aut
PE1(config-router)#no auto-summary
PE1(config-router)#add
PE1(config-router)#address-family ipv4vrfVPN_A
PE1(config-router-af)#network 10.1.13.0
PE1(config-router-af)#do ping vrfVPN_A 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/64 ms
PE1(config-router-af)#
PE1(config-router-af)#redistribute bgp 100 metric 5
PE1(config-router-af)#



CE2(config)#router rip
CE2(config-router)#version 2
CE2(config-router)#no au
CE2(config-router)#no auto-summary
CE2(config-router)#network 10.1.24.0
CE2(config-router)#network 2.2.2.0
CE2(config-router)#network 22.22.22.0
CE2(config-router)#



PE2(config)#router rip
PE2(config-router)#no aut
PE2(config-router)#no auto-summary
PE2(config-router)#version 2
PE2(config-router)#add
PE2(config-router)#address-family ipv4vrfVPN_A
PE2(config-router-af)#network 10.1.24.0
PE2(config-router-af)#do ping vrfVPN_A 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/28/108 ms
PE2(config-router-af)#
PE2(config-router-af)#redistribute bgp 100 metric 5
PE2(config-router-af)#






PE2(config-router-af)#router bgp 100
PE2(config-router)#address
PE2(config-router)#address-family ipv4vrfVPN_A
PE2(config-router-af)#redis
PE2(config-router-af)#redistribute rip ?
metric     Metric for redistributed routes
  route-map  Route map reference
<cr>

PE2(config-router-af)#redistribute rip me
PE2(config-router-af)#redistribute rip metric ?
<0-4294967295>  Default metric

PE2(config-router-af)#redistribute rip
PE2(config-router-af)#




PE1(config-router-af)#redistribute bgp 100 metric 5
PE1(config-router-af)#router bgp 100
PE1(config-router)#add
PE1(config-router)#address-family ipv4vrfVPN_A
PE1(config-router-af)#redi
PE1(config-router-af)#redistribute ri
PE1(config-router-af)#redistribute rip
PE1(config-router-af)#





CE1#showip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPFNSSA external type 1, N2 - OSPFNSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       2.2.2.2/32 [120/5] via 10.1.13.3, 00:00:19, Serial1/0
R       2.2.2.0/24 [120/5] via 10.1.13.3, 00:00:19, Serial1/0
     22.0.0.0/32 is subnetted, 1 subnets
R       22.22.22.22 [120/5] via 10.1.13.3, 00:00:19, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.13.0 is directly connected, Serial1/0
R       10.1.24.0 [120/5] via 10.1.13.3, 00:00:19, Serial1/0
     11.0.0.0/32 is subnetted, 1 subnets
C       11.11.11.11 is directly connected, Loopback1
CE1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/34/88 ms
CE1#ping 22.22.22.22

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/44/128 ms
CE1#





CE2#showip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPFNSSA external type 1, N2 - OSPFNSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/5] via 10.1.24.4, 00:00:11, Serial1/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     22.0.0.0/32 is subnetted, 1 subnets
C       22.22.22.22 is directly connected, Loopback1
     10.0.0.0/24 is subnetted, 2 subnets
R       10.1.13.0 [120/5] via 10.1.24.4, 00:00:11, Serial1/0
C       10.1.24.0 is directly connected, Serial1/0
     11.0.0.0/32 is subnetted, 1 subnets
R       11.11.11.11 [120/5] via 10.1.24.4, 00:00:11, Serial1/0
CE2#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/43/124 ms
CE2#ping 11.11.11.11

Type escape sequence to abort.
Sending 5, 100-byte ICMPEchos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/54/152 ms
CE2#




PE1#showipbgpvpnv4 all
BGP table version is 24, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrfVPN_A)
*> 1.1.1.1/32       10.1.13.1                1         32768 ?
*>i2.2.2.0/24       4.4.4.4                  0    100      0 ?
*>i2.2.2.2/32       4.4.4.4                  1    100      0 ?
*> 10.1.13.0/24     0.0.0.0                  0         32768 ?
*>i10.1.24.0/24     4.4.4.4                  0    100      0 ?
*> 11.11.11.11/32   10.1.13.1                1         32768 ?
*>i22.22.22.22/32   4.4.4.4                  1    100      0 ?
PE1#



PE2#showipbgpvpnv4 all
BGP table version is 24, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrfVPN_A)
*>i1.1.1.1/32       3.3.3.3                  1    100      0 ?
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 2.2.2.2/32       10.1.24.2                1         32768 ?
*>i10.1.13.0/24     3.3.3.3                  0    100      0 ?
*> 10.1.24.0/24     0.0.0.0                  0         32768 ?
*>i11.11.11.11/32   3.3.3.3                  1    100      0 ?
*> 22.22.22.22/32   10.1.24.2                1         32768 ?
PE2#

No comments:

Post a Comment