IPv6: Tunneling IPv6 over IPv6
·
Let
me take a small topology to configure IPV6 tunneling over IPv6.
·
OSPFv3
is configured between R1 & R2 and R3 & R4
·
RIPng
is configured between R2 and R3
·
If
I need to connect R1 and R4’s OSPFv3 network, then I need to tunnel the IPv6
traffic through IPv6.
Configs:
R1#show run int fa0/0
Building configuration...
Current configuration : 134 bytes
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address
2001:12::1/64
ipv6 enable
ipv6 ospf 1
area 0
end
R1#show run int loop0
Building configuration...
Current configuration : 89 bytes
!
interface Loopback0
no ip address
ipv6 address
2001:1::1/64
ipv6 ospf 1
area 0
end
R1#
R2(config-if)#do show run int fa0/0
Building configuration...
Current configuration : 134 bytes
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address
2001:12::2/64
ipv6 enable
ipv6 ospf 1
area 0
end
R2(config-if)#
R1#show ipv6 ospf neighbor
Neighbor ID
Pri State Dead Time Interface ID Interface
2.2.2.2
1 FULL/DR 00:00:38 4 FastEthernet0/0
R1#
R2(config-if)#do show ipv6 ospf nei
Neighbor ID
Pri State Dead Time Interface ID Interface
1.1.1.1
1 FULL/BDR 00:00:38 4 FastEthernet0/0
R2(config-if)#
R3(config-if)#do show run int fa0/0
Building configuration...
Current configuration : 121 bytes
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address
2001:34::3/64
ipv6 ospf 1
area 0
end
R3(config-if)#
R4#show run int fa0/0
Building configuration...
Current configuration : 121 bytes
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address
2001:34::4/64
ipv6 ospf 1
area 0
end
R4#show run int loop0
Building configuration...
Current configuration : 89 bytes
!
interface Loopback0
no ip address
ipv6 address
2001:4::4/64
ipv6 ospf 1
area 0
end
R4#
R3(config-if)#do show ipv6 ospf nei
Neighbor ID
Pri State Dead Time Interface ID Interface
4.4.4.4
1 FULL/DR 00:00:38 4 FastEthernet0/0
R3(config-if)#
R4#show ipv6 ospf nei
Neighbor ID
Pri State Dead Time Interface ID Interface
3.3.3.3
1 FULL/BDR 00:00:31 4 FastEthernet0/0
R4#
Observation:
·
OSPFv3
is up between R1-R2 and R3-R4
·
Let
me configure RIPng between R2 and R3
R2(config-if)#do show run int fa0/1
Building configuration...
Current configuration : 145 bytes
!
interface FastEthernet0/1
ip address
10.1.23.2 255.255.255.0
duplex auto
speed auto
ipv6 address
2001:32::2/64
ipv6 rip
RIPng enable
end
R2(config-if)#do show run int loop0
Building configuration...
Current configuration : 113 bytes
!
interface Loopback0
ip address
2.2.2.2 255.255.255.255
ipv6 address
2001:2::2/64
ipv6 rip
RIPng enable
end
R2(config-if)#
R3(config-if)#do show run int fa0/1
Building configuration...
Current configuration : 145 bytes
!
interface FastEthernet0/1
ip address
10.1.23.3 255.255.255.0
duplex auto
speed auto
ipv6 address
2001:32::3/64
ipv6 rip
RIPng enable
end
R3(config-if)#do show run int loop0
Building configuration...
Current configuration : 113 bytes
!
interface Loopback0
ip address
3.3.3.3 255.255.255.255
ipv6 address
2001:3::3/64
ipv6 rip
RIPng enable
end
R3(config-if)#
R2(config-if)#do ping 2001:3::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:3::3, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 4/12/36 ms
R2(config-if)#
R3(config-if)#do ping 2001:2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2::2, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 4/24/104 ms
R3(config-if)#
Observation:
·
RIPng
is configured between R2 and R3
·
R2’s
loopback 2001:2::2/64 is advertised into RIPng
·
R3’s
loopback 2001:3::3/64 is advertised into RIPng
·
They
are able to ping their respective loopbacks.
·
Let
me create IPv6 tunnel through R2 and R3 to pass IPv6 traffic
·
I’m
going to use gre mode for the tunnel
·
This
mode is used for IPV6/IPV6.
·
Tunnel
source, destination and interface address all are IPv6 addresses.
·
Let
me advertise it into OSPF as well
R2(config-if)#do show run int tun1
Building configuration...
Current configuration : 165 bytes
!
interface Tunnel1
no ip address
ipv6 address
2001:23::2/64
ipv6 ospf 1
area 0
tunnel source
2001:2::2
tunnel
destination 2001:3::3
tunnel mode
gre ipv6
end
R2(config-if)#
R3(config-if)#do show run int tun1
Building configuration...
Current configuration : 165 bytes
!
interface Tunnel1
no ip address
ipv6 address
2001:23::3/64
ipv6 ospf 1
area 0
tunnel source
2001:3::3
tunnel
destination 2001:2::2
tunnel mode
gre ipv6
end
R3(config-if)#
R2#show ipv6 int tun1
Tunnel1 is up, line protocol is up
IPv6 is
enabled, link-local address is FE80::C001:25FF:FE30:0
Global
unicast address(es):
2001:23::2, subnet is 2001:23::/64
Joined group
address(es):
FF02::1
FF02::2
FF02::5
FF02::1:FF00:2
FF02::1:FF30:0
MTU is 1456
bytes
ICMP error
messages limited to one every 100 milliseconds
ICMP
redirects are enabled
ND DAD is
enabled, number of DAD attempts: 1
ND reachable
time is 30000 milliseconds
Hosts use
stateless autoconfig for addresses.
R2#
R3#show ipv6 int tun1
Tunnel1 is up, line protocol is up
IPv6 is
enabled, link-local address is FE80::C003:25FF:FE30:0
Global
unicast address(es):
2001:23::3, subnet is 2001:23::/64
Joined group
address(es):
FF02::1
FF02::2
FF02::5
FF02::1:FF00:3
FF02::1:FF30:0
MTU is 1456
bytes
ICMP error
messages limited to one every 100 milliseconds
ICMP
redirects are enabled
ND DAD is
enabled, number of DAD attempts: 1
ND reachable
time is 30000 milliseconds
Hosts use
stateless autoconfig for addresses.
R3#
Observation:
·
Tunnel
is up between R2 and R3
·
Tunnel
interface is advertised into OSPFv3 as well.
·
Now,
let me see routing tables:
R1#show
ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R -
RIP, B - BGP
U -
Per-user Static route
I1 -
ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O -
OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 -
OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C
2001:1::/64 [0/0]
via ::,
Loopback0
L
2001:1::1/128 [0/0]
via ::,
Loopback0
O 2001:4::4/128 [110/11131]
via
FE80::C001:25FF:FE30:0, FastEthernet0/0
C
2001:12::/64 [0/0]
via ::,
FastEthernet0/0
L
2001:12::1/128 [0/0]
via ::,
FastEthernet0/0
O 2001:23::/64 [110/11121]
via
FE80::C001:25FF:FE30:0, FastEthernet0/0
O 2001:34::/64 [110/11131]
via
FE80::C001:25FF:FE30:0, FastEthernet0/0
L FE80::/10
[0/0]
via ::,
Null0
L FF00::/8
[0/0]
via ::,
Null0
R1#
R1#ping 2001:4::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:4::4, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 8/35/104 ms
R1#
R4#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R -
RIP, B - BGP
U -
Per-user Static route
I1 -
ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O -
OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 -
OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O 2001:1::1/128 [110/11131]
via
FE80::C003:25FF:FE30:0, FastEthernet0/0
C
2001:4::/64 [0/0]
via ::,
Loopback0
L
2001:4::4/128 [0/0]
via ::,
Loopback0
O 2001:12::/64 [110/11131]
via
FE80::C003:25FF:FE30:0, FastEthernet0/0
O 2001:23::/64 [110/11121]
via
FE80::C003:25FF:FE30:0, FastEthernet0/0
C
2001:34::/64 [0/0]
via ::,
FastEthernet0/0
L
2001:34::4/128 [0/0]
via ::,
FastEthernet0/0
L FE80::/10
[0/0]
via ::, Null0
L FF00::/8
[0/0]
via ::,
Null0
R4#
R4#ping 2001:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1::1, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 8/24/72 ms
R4#
Observation:
·
R1
has received R3-R4 link, GRE Tunnel link and R4’s loopback0
·
R4
has received R1-R2 link, GRE Tunnel link and R1’s loopback0
·
Ping
also successful between R1 and R4