Wednesday, 10 October 2012

CE-PE Routing: Configuring using EIGRP


CE-PE Routing: Configuring using EIGRP

·         There are many options for CE-PE routing.

·         In this post, let me configure routing between CE-PE using protocol EIGRP

·         In PE router, we need to enable the CE-PE link under “address-family ipv4 vrf VPN_A” in EIGRP.

·         In CE router, we need to enable the CE-PE link normally in EIGRP.

 Let me take a basic topology to configure this:


VRF Configuration:

 

PE1:

 

PE1(config)#ip vrf VPN_A

PE1(config-vrf)#rd 100:1

PE1(config-vrf)#route-target both 100:1

PE1(config-vrf)#do show run int ser1/0

Building configuration...

 

Current configuration : 87 bytes

!

interface Serial1/0

 ip address 10.1.13.3 255.255.255.0

 serial restart-delay 0

end

 

PE1(config-vrf)#int ser1/0

PE1(config-if)#ip vrf forwarding VPN_A

% Interface Serial1/0 IP address 10.1.13.3 removed due to enabling VRF VPN_A

PE1(config-if)#ip address 10.1.13.3 255.255.255.0

PE1(config-if)#do ping vrf VPN_A 10.1.13.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.13.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/17/44 ms

PE1(config-if)#

 

CE1:

 

CE1(config-if)#do show run int ser1/0

Building configuration...

 

Current configuration : 87 bytes

!

interface Serial1/0

 ip address 10.1.13.1 255.255.255.0

 serial restart-delay 0

end

 

CE1(config-if)#do ping 10.1.13.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.13.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/25/44 ms

CE1(config-if)#

 

Observation:

·         CE1-PE1 link is up

 

PE1:

 

PE2(config-router-af)#ip vrf VPN_A

PE2(config-vrf)#rd 100:1

PE2(config-vrf)#route-target both 100:1

PE2(config-vrf)#do show run int ser1/0

Building configuration...

 

Current configuration : 87 bytes

!

interface Serial1/0

 ip address 10.1.24.4 255.255.255.0

 serial restart-delay 0

end

 

PE2(config-vrf)#int ser1/0

PE2(config-if)#do show run int ser1/0

Building configuration...

 

Current configuration : 87 bytes

!

interface Serial1/0

 ip address 10.1.24.4 255.255.255.0

 serial restart-delay 0

end

 

PE2(config-if)#ip vrf forwarding VPN_A

% Interface Serial1/0 IP address 10.1.24.4 removed due to enabling VRF VPN_A

PE2(config-if)#ip address 10.1.24.4 255.255.255.0

PE2(config-if)#do ping vrf VPN_A 10.1.24.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.24.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/36 ms

PE2(config-if)#

 

CE2:

 

CE2(config-if)#do show run int ser1/0

Building configuration...

 

Current configuration : 87 bytes

!

interface Serial1/0

 ip address 10.1.24.2 255.255.255.0

 serial restart-delay 0

end

 

CE2(config-if)#do ping 10.1.24.4

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.24.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/64 ms

CE2(config-if)#

 

Observation:

·         CE2-PE2 link is up

 

IGP-OSPF Configuration between PE1-PE2:

 

PE1(config-if)#do show run | begin router ospf

router ospf 1

 router-id 3.3.3.3

 log-adjacency-changes

 network 3.3.3.3 0.0.0.0 area 0

 network 100.1.34.3 0.0.0.0 area 0

!

PE2(config-if)#do show run | begin router ospf

router ospf 1

 router-id 4.4.4.4

 log-adjacency-changes

 network 4.4.4.4 0.0.0.0 area 0

 network 100.1.34.4 0.0.0.0 area 0

!

 

MP-iBGP configuration between PE1-PE2:

 

PE1(config)#do show run | begin router bgp

router bgp 100

 bgp router-id 3.3.3.3

 no bgp default ipv4-unicast

 bgp log-neighbor-changes

 neighbor 4.4.4.4 remote-as 100

 neighbor 4.4.4.4 update-source Loopback0

 !

 address-family vpnv4

  neighbor 4.4.4.4 activate

  neighbor 4.4.4.4 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf VPN_A

  no synchronization

 exit-address-family

!

 

PE2(config-router-af)#do show run | begin router bgp

router bgp 100

 bgp router-id 4.4.4.4

 no bgp default ipv4-unicast

 bgp log-neighbor-changes

 neighbor 3.3.3.3 remote-as 100

 neighbor 3.3.3.3 update-source Loopback0

 !

 address-family vpnv4

  neighbor 3.3.3.3 activate

  neighbor 3.3.3.3 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf VPN_A

 no synchronization

 exit-address-family

!

 

Configuring MPLS in the Core (between PE1-PE2):

 

PE1(config)#int ser1/1

PE1(config-if)#mpls ip

PE1(config-if)#

 

PE2(config)#int ser1/1

PE2(config-if)#mpls ip

PE2(config-if)#

 

Configuring EIGRP between CE1-PE1:

 

 

CE1(config-if)#router eigrp 100

CE1(config-router)#eigrp router-id 1.1.1.1

CE1(config-router)#network 10.1.13.1 0.0.0.0

CE1(config-router)#network 1.1.1.1 0.0.0.0

CE1(config-router)#do show ip eigrp nei

IP-EIGRP neighbors for process 100

CE1(config-router)#

 

PE1(config)#router eigrp 100

PE1(config-router)#eigrp router-id 3.3.3.3

PE1(config-router)#address-family ipv4 vrf VPN_A

PE1(config-router-af)#network 10.1.13.3 0.0.0.0

PE1(config-router-af)#autonomous-system 100

PE1(config-router-af)#end

PE1#

 

CE1#show ip eigrp neighbors

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   10.1.13.3               Se1/0             14 00:03:56   64   384  0  10

CE1#

 

 

PE1#show ip eigrp vrf VPN_A neighbors

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   10.1.13.1               Se1/0             14 00:04:19   57   342  0  7

PE1#

PE1#show ip route vrf VPN_A

 

Routing Table: VPN_A

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

D       1.1.1.1 [90/2297856] via 10.1.13.1, 00:01:08, Serial1/0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.13.0 is directly connected, Serial1/0

PE1#ping vrf VPN_A 1.1.1.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/13/32 ms

PE1#

 

CE2(config-if)#router eigrp 100

CE2(config-router)#no auto-summary

CE2(config-router)#eigrp router-id 2.2.2.2

CE2(config-router)#network 10.1.24.2 0.0.0.0

CE2(config-router)#network 2.2.2.2 0.0.0.0

CE2(config-router)#

*Mar  1 00:54:17.363: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.1.24.4 (Serial1/0) is up: new adjacency

CE2(config-router)#

 

PE2(config-router-af)#router eigrp 100

PE2(config-router)#no auto-summary

PE2(config-router)#address-family ipv4 vrf VPN_A

PE2(config-router-af)#autonomous-system 100

PE2(config-router-af)#no auto

PE2(config-router-af)#network 10.1.24.4 0.0.0.0

*Mar  1 00:54:16.651: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 100: Neighbor 10.1.24.2 (Serial1/0) is up: new adjacency

PE2(config-router-af)#

PE2(config-router-af)#

 

CE2#show ip eigrp neighbors

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   10.1.24.4               Se1/0             10 00:00:41   64   384  0  3

CE2#

 

PE2#show ip eigrp vrf VPN_A neighbors

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   10.1.24.2               Se1/0             10 00:00:18   69   414  0  3

PE2#show ip route vrf VPN_A

 

Routing Table: VPN_A

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

D       2.2.2.2 [90/2297856] via 10.1.24.2, 00:00:26, Serial1/0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.24.0 is directly connected, Serial1/0

PE2#ping vrf VPN_A 2.2.2.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/28 ms

PE2#

 

Mutual redistribution between EIGRP and BGP:

 

PE1(config)#router eigrp 100

PE1(config-router)#address-family ipv4 vrf VPN_A

PE1(config-router-af)#redistribute bgp 100 metric 1 1 1 1 1

PE1(config-router-af)#router bgp 100

PE1(config-router)#address-family ipv4 vrf VPN_A

PE1(config-router-af)#redistribute eigrp 100

PE1(config-router-af)#redistribute connected

PE1(config-router-af)#

 

PE2(config)#router eigrp 100

PE2(config-router)#address-family ipv4 vrf VPN_A

PE2(config-router-af)#redistribute bgp 100 metric 1 1 1 1 1

PE2(config-router-af)#router bgp 100

PE2(config-router)#address-family ipv4 vrf VPN_A

PE2(config-router-af)#redistribute eigrp 100

PE2(config-router-af)#redistribute connected

PE2(config-router-af)#

 

Now, let’s check Routing tables in CE routers:

 

CE1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

     2.0.0.0/32 is subnetted, 1 subnets

D       2.2.2.2 [90/2809856] via 10.1.13.3, 00:04:55, Serial1/0

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/0

D       10.1.24.0 [90/2681856] via 10.1.13.3, 00:04:55, Serial1/0

CE1#ping 2.2.2.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/30/68 ms

CE1#

 

CE2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

D       1.1.1.1 [90/2809856] via 10.1.24.4, 00:04:06, Serial1/0

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 2 subnets

D       10.1.13.0 [90/2681856] via 10.1.24.4, 00:04:06, Serial1/0

C       10.1.24.0 is directly connected, Serial1/0

CE2#ping 1.1.1.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/32/76 ms

CE2#

 

Observation:

·         CE1 has the route of CE2’s loopback 2.2.2.2/32

·         CE2 has the route of CE1’s loopback 1.1.1.1/32

·         CE routers install these routes form other CE as Internal EIGRP route, D routes.

·         Internal routes from one CE came as internal routes in other CE also.

 

·         Now, let’s see what will happen for External routes.

·         Let me create another loopback in CE routers and redistribute into EIGRP to make as External route.

 

CE1(config)#int loop1

CE1(config-if)#ip address 11.11.11.11 255.255.255.255

CE1(config-if)#route-map LOOP

CE1(config-route-map)#match interface loop1

CE1(config-route-map)#router eigrp 100

CE1(config-router)#redistribute connected route-map LOOP metric 1 1 1 1 1

CE1(config-router)#

 

CE2(config)#int loop1

CE2(config-if)#ip address 22.22.22.22 255.255.255.255

CE2(config-if)#route-map LOOP

CE2(config-route-map)#match interface loop1

CE2(config-route-map)#router eigrp 100

CE2(config-router)#redistribute connected route-map LOOP metric 1 1 1 1 1

CE2(config-router)#

 

Now, Let’s see the routing tables in CE       routers:

 

CE1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

     2.0.0.0/32 is subnetted, 1 subnets

D       2.2.2.2 [90/2809856] via 10.1.13.3, 00:14:18, Serial1/0

     22.0.0.0/32 is subnetted, 1 subnets

D EX    22.22.22.22 [170/2561024256] via 10.1.13.3, 00:01:03, Serial1/0

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/0

D       10.1.24.0 [90/2681856] via 10.1.13.3, 00:14:18, Serial1/0

     11.0.0.0/32 is subnetted, 1 subnets

C       11.11.11.11 is directly connected, Loopback1

CE1#

 

CE1#ping 22.22.22.22

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/34/68 ms

CE1#

 

CE2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

D       1.1.1.1 [90/2809856] via 10.1.24.4, 00:15:08, Serial1/0

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     22.0.0.0/32 is subnetted, 1 subnets

C       22.22.22.22 is directly connected, Loopback1

     10.0.0.0/24 is subnetted, 2 subnets

D       10.1.13.0 [90/2681856] via 10.1.24.4, 00:15:08, Serial1/0

C       10.1.24.0 is directly connected, Serial1/0

     11.0.0.0/32 is subnetted, 1 subnets

D EX    11.11.11.11 [170/2561024256] via 10.1.24.4, 00:04:23, Serial1/0

CE2#

CE2#ping 11.11.11.11

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/33/72 ms

CE2#

 

Observation:

·         CE1 has the route of CE2’s loopback 22.22.22.22/32

·         CE2 has the route of CE1’s loopback 11.11.11.11/32

·         CE routers install these routes form other CE as External EIGRP route, D EX routes.

·         External routes from one CE came as External routes in other CE.

 

·         Now, let’s try anoter scenario, where the CEs are in different EIGRP AS.

·         Let me configure CE2 in EIGRP AS 200

 

CE2(config)#no router eigrp 100

 

*Mar  1 01:22:19.479: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.1.24.4 (Serial1/0) is down: interface down

CE2(config)#router eigrp 200

CE2(config-router)# redistribute connected metric 1 1 1 1 1 route-map LOOP

CE2(config-router)# network 2.2.2.2 0.0.0.0

CE2(config-router)# network 10.1.24.2 0.0.0.0

CE2(config-router)# no auto-summary

CE2(config-router)# eigrp router-id 2.2.2.2

CE2(config-router)#!

CE2(config-router)#

 

PE2(config)#no router eigrp 100

PE2(config)#router eigrp 200

PE2(config-router)# no auto-summary

PE2(config-router)# !

PE2(config-router)# address-family ipv4 vrf VPN_A

PE2(config-router-af)#  redistribute bgp 100 metric 1 1 1 1 1

PE2(config-router-af)#  network 10.1.24.4 0.0.0.0

PE2(config-router-af)#  network 10.0.0.0

PE2(config-router-af)#  no auto-summary

PE2(config-router-af)#  autonomous-system 200

PE2(config-router-af)#

*Mar  1 01:24:05.967: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 200: Neighbor 10.1.24.2 (Serial1/0) is up: new adjacency

PE2(config-router-af)#

 

PE2(config-router-af)#router bgp 100

PE2(config-router)#address-family ipv4 vrf VPN_A

PE2(config-router-af)#redistribute eigrp 200

PE2(config-router-af)#

 

Now, let’s see the routing tables in CE routers:

 

CE1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

     2.0.0.0/32 is subnetted, 1 subnets

D EX    2.2.2.2 [170/2560512256] via 10.1.13.3, 00:00:43, Serial1/0

     22.0.0.0/32 is subnetted, 1 subnets

D EX    22.22.22.22 [170/2560512256] via 10.1.13.3, 00:00:43, Serial1/0

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/0

D EX    10.1.24.0 [170/2560512256] via 10.1.13.3, 00:01:54, Serial1/0

     11.0.0.0/32 is subnetted, 1 subnets

C       11.11.11.11 is directly connected, Loopback1

CE1#

 

CE2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

D EX    1.1.1.1 [170/2560512256] via 10.1.24.4, 00:01:55, Serial1/0

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     22.0.0.0/32 is subnetted, 1 subnets

C       22.22.22.22 is directly connected, Loopback1

     10.0.0.0/24 is subnetted, 2 subnets

D EX    10.1.13.0 [170/2560512256] via 10.1.24.4, 00:01:55, Serial1/0

C       10.1.24.0 is directly connected, Serial1/0

     11.0.0.0/32 is subnetted, 1 subnets

D EX    11.11.11.11 [170/2560512256] via 10.1.24.4, 00:01:55, Serial1/0

CE2#

 

Observation:

·         CE1 has the routes from CE2’s as EIGRP External routes.

·         CE2 has the routes from CE2’s as EIGRP External routes.

·         If the CEs are in different EIGRP ASes, then all the routes will appear as External in other CE router.

 

EIGRP SOO:

·         Concept is similar to BGP SOO

 

·         In multihomed environments, if CE routers have backdoor link, then there is a probability of getting loops.

·         In EIGRP, there is an extended community called Site Of Origin, SOO attribute to avoid this situation.

 

·         This is used basically to tag the route where it is initially originated, so that it can never send back to the same source.

·         Its generally configure in PE router, towards the CE.

·         Let’s see how to configure this.

PE1(config)#route-map SITE

PE1(config-route-map)#set extcommunity soo 333:3

PE1(config-route-map)#

PE1(config-router-af)#int ser1/0

PE1(config-if)#ip vrf route

PE1(config-if)#ip vrf ?

  forwarding  Configure forwarding table

  receive     Add Interface Address into VRF Table

  sitemap     Configure route-map for routes received from this site

 

PE1(config-if)#ip vrf sitemap SITE

PE1(config-if)#

*Mar  1 01:35:03.399: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 100: Neighbor 10.1.13.1 (Serial1/0) is down: SoO changed

*Mar  1 01:35:03.919: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 100: Neighbor 10.1.13.1 (Serial1/0) is up: new adjacency

PE1(config-if)#

 

PE2(config)#route-map SITE

PE2(config-route-map)#set extcommunity soo 444:4

PE2(config-route-map)#int ser1/0

PE2(config-if)#ip vrf sitemap SITE

PE2(config-if)#

*Mar  1 01:36:07.259: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 200: Neighbor 10.1.24.2 (Serial1/0) is down: SoO changed

PE2(config-if)#

*Mar  1 01:36:10.883: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 200: Neighbor 10.1.24.2 (Serial1/0) is up: new adjacency

PE2(config-if)#

 

PE1#show ip bgp vpnv4 all 1.1.1.1

BGP routing table entry for 100:1:1.1.1.1/32, version 30

Paths: (1 available, best #1, table VPN_A)

  Advertised to update-groups:

     1

  Local

    10.1.13.1 from 0.0.0.0 (3.3.3.3)

      Origin incomplete, metric 2297856, localpref 100, weight 32768, valid, sourced, best

      Extended Community: SoO:333:3 RT:100:1

        Cost:pre-bestpath:128:2297856 (default-2145185791) 0x8800:32768:0

        0x8801:100:640000 0x8802:65281:1657856 0x8803:65281:1500

      mpls labels in/out 19/nolabel

PE1#

PE1#show ip bgp vpnv4 all 11.11.11.11

BGP routing table entry for 100:1:11.11.11.11/32, version 31

Paths: (1 available, best #1, table VPN_A)

  Advertised to update-groups:

     1

  Local

    10.1.13.1 from 0.0.0.0 (3.3.3.3)

      Origin incomplete, metric 2560512256, localpref 100, weight 32768, valid, sourced, best

      Extended Community: SoO:333:3 RT:100:1

        Cost:pre-bestpath:129:2560512256 (default+413028609) 0x8800:0:0

        0x8801:100:512256 0x8802:257:2560000000 0x8803:257:1 0x8804:0:16843009

        0x8805:11:0

      mpls labels in/out 17/nolabel

PE1#

 

PE2#show ip bgp vpnv4 all 2.2.2.2

BGP routing table entry for 100:1:2.2.2.2/32, version 33

Paths: (1 available, best #1, table VPN_A)

Flag: 0x820

  Advertised to update-groups:

     1

  Local

    10.1.24.2 from 0.0.0.0 (4.4.4.4)

      Origin incomplete, metric 2297856, localpref 100, weight 32768, valid, sourced, best

      Extended Community: SoO:444:4 RT:100:1

        Cost:pre-bestpath:128:2297856 (default-2145185791) 0x8800:32768:0

        0x8801:200:640000 0x8802:65281:1657856 0x8803:65281:1500

      mpls labels in/out 18/nolabel

PE2#

PE2#show ip bgp vpnv4 all 22.22.22.22

BGP routing table entry for 100:1:22.22.22.22/32, version 34

Paths: (1 available, best #1, table VPN_A)

Flag: 0x820

  Advertised to update-groups:

     1

  Local

    10.1.24.2 from 0.0.0.0 (4.4.4.4)

      Origin incomplete, metric 2560512256, localpref 100, weight 32768, valid, sourced, best

      Extended Community: SoO:444:4 RT:100:1

        Cost:pre-bestpath:129:2560512256 (default+413028609) 0x8800:0:0

        0x8801:200:512256 0x8802:257:2560000000 0x8803:257:1 0x8804:0:33686018

        0x8805:11:0

      mpls labels in/out 21/nolabel

PE2#
 
Observation:

 ·         PE1 assigned the SOO 333:3 to 1.1.1.1/32 and 11.11.11.11/32 which are received from CE1
·         PE2 assigned the SOO 444:4 to 2.2.2.2/32 and 22.22.22.22/32 which are received from CE2

1 comment: