Wednesday 10 October 2012

PPP: IP address negotiated


PPP: IP address negotiated

 ·         In this post, let me configure PPP to negotiate the IP address form the peer.
  ·         Let me take a small topology to configure this:

R1-----s1/0---------------------s1/0----R2
10.1.1.1----------------------------Client

R2#show run int ser1/0

Building configuration...

Current configuration : 93 bytes

!

interface Serial1/0

 ip address negotiated

 encapsulation ppp

 serial restart-delay 0

end

 

R2#

R1(config-if)#do show run int ser1/0

Building configuration...

 

Current configuration : 139 bytes

!

interface Serial1/0

 ip address 10.1.1.1 255.255.255.0

 encapsulation ppp

 peer default ip address 10.1.1.3

 serial restart-delay 0

end

 

R1(config-if)#

R1(config-if)#

*Mar  1 00:35:47.939: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up

*Mar  1 00:35:47.943: Se1/0 PPP: Using default call direction

*Mar  1 00:35:47.943: Se1/0 PPP: Treating connection as a dedicated line

*Mar  1 00:35:47.943: Se1/0 PPP: Session handle[8A000003] Session id[3]

*Mar  1 00:35:47.943: Se1/0 PPP: Phase is ESTABLISHING, Active Open

*Mar  1 00:35:47.947: Se1/0 LCP: O CONFREQ [Closed] id 5 len 10

*Mar  1 00:35:47.947: Se1/0 LCP:    MagicNumber 0x00315735 (0x050600315735)

*Mar  1 00:35:48.055: Se1/0 PPP: I pkt type 0xC021, datagramsize 14 link[ppp]

*Mar  1 00:35:48.055: Se1/0 PPP: I pkt type 0xC021, datagramsize 14 link[ppp]

*Mar  1 00:35:48.059: Se1/0 LCP: I CONFREQ [REQsent] id 4 len 10

*Mar  1 00:35:48.059: Se1/0 LCP:    MagicNumber 0x01315759 (0x050601315759)

*Mar  1 00:35:48.059: Se1/0 LCP: O CONFACK [REQsent] id 4 len 10

*Mar  1 00:35:48.059: Se1/0 LCP:    MagicNumber 0x01315759 (0x050601315759)

*Mar  1 00:35:48.063: Se1/0 LCP: I CONFACK [ACKsent]

R1(config-if)# id 5 len 10

*Mar  1 00:35:48.063: Se1/0 LCP:    MagicNumber 0x00315735 (0x050600315735)

*Mar  1 00:35:48.063: Se1/0 LCP: State is Open

*Mar  1 00:35:48.063: Se1/0 PPP: Phase is FORWARDING, Attempting Forward

*Mar  1 00:35:48.067: Se1/0 PPP: Phase is ESTABLISHING, Finish LCP

*Mar  1 00:35:48.071: Se1/0 PPP: Phase is UP

*Mar  1 00:35:48.071: Se1/0 IPCP: O CONFREQ [Closed] id 1 len 10

*Mar  1 00:35:48.071: Se1/0 IPCP:    Address 10.1.1.1 (0x03060A010101)

*Mar  1 00:35:48.075: Se1/0 CDPCP: O CONFREQ [Closed] id 1 len 4

*Mar  1 00:35:48.075: Se1/0 PPP: Process pending ncp packets

*Mar  1 00:35:48.183: Se1/0 PPP: I pkt type 0x8021, datagramsize 14 link[ip]

*Mar  1 00:35:48.183: Se1/0 PPP: I pkt type 0x8207, datagramsize 8 link[cdp]

*Mar  1 00:35:48.187: Se1/0 PPP: I pkt type 0x8021, datagramsize 14 link[ip]

*Mar  1 00:35:48.187: Se1/0 IPCP: I CONFREQ [REQsent] id 1 len 10

*Mar  1 00:35:48.187: Se1/0 IPCP:    Address 0.0.0.0 (0x030600000000)

*Mar  1 00:35:48.191: Se1/0 IPCP:

R1(config-if)#O CONFNAK [REQsent] id 1 len 10

*Mar  1 00:35:48.191: Se1/0 IPCP:    Address 10.1.1.3 (0x03060A010103)

*Mar  1 00:35:48.191: Se1/0 IPCP: I CONFACK [REQsent] id 1 len 10

*Mar  1 00:35:48.195: Se1/0 IPCP:    Address 10.1.1.1 (0x03060A010101)

*Mar  1 00:35:48.195: Se1/0 CDPCP: I CONFREQ [REQsent] id 1 len 4

*Mar  1 00:35:48.195: Se1/0 CDPCP: O CONFACK [REQsent] id 1 len 4

*Mar  1 00:35:48.227: Se1/0 PPP: I pkt type 0x8021, datagramsize 14 link[ip]

*Mar  1 00:35:48.227: Se1/0 IPCP: I CONFREQ [ACKrcvd] id 2 len 10

*Mar  1 00:35:48.227: Se1/0 IPCP:    Address 10.1.1.3 (0x03060A010103)

*Mar  1 00:35:48.227: Se1/0 IPCP: O CONFACK [ACKrcvd] id 2 len 10

*Mar  1 00:35:48.227: Se1/0 IPCP:    Address 10.1.1.3 (0x03060A010103)

*Mar  1 00:35:48.227: Se1/0 IPCP: State is Open

*Mar  1 00:35:48.231: Se1/0 IPCP: Install route to 10.1.1.3

*Mar  1 00:35:49.067: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

R1(config-if)#

*Mar  1 00:35:50.063: Se1/0 CDPCP: Timeout: State ACKsent

*Mar  1 00:35:50.063: Se1/0 CDPCP: O CONFREQ [ACKsent] id 2 len 4

*Mar  1 00:35:50.143: Se1/0 PPP: I pkt type 0x8207, datagramsize 8 link[cdp]

*Mar  1 00:35:50.143: Se1/0 CDPCP: I CONFACK [ACKsent] id 2 len 4

*Mar  1 00:35:50.143: Se1/0 CDPCP: State is Open

R1(config-if)#

 

R2#

*Mar  1 00:35:47.975: Se1/0 PPP: I pkt type 0xC021, datagramsize 14 link[ppp]

*Mar  1 00:35:47.975: Se1/0 LCP: I CONFREQ [Open] id 5 len 10

*Mar  1 00:35:47.975: Se1/0 LCP:    MagicNumber 0x00315735 (0x050600315735)

*Mar  1 00:35:47.979: Se1/0 CDPCP: State is Closed

*Mar  1 00:35:47.979: Se1/0 IPCP: State is Closed

*Mar  1 00:35:47.983: Se1/0 PPP: Phase is TERMINATING

*Mar  1 00:35:47.983: Se1/0 PPP: Phase is ESTABLISHING

*Mar  1 00:35:47.987: Se1/0 LCP: O CONFREQ [Open] id 4 len 10

*Mar  1 00:35:47.987: Se1/0 LCP:    MagicNumber 0x01315759 (0x050601315759)

*Mar  1 00:35:47.987: Se1/0 LCP: O CONFACK [Open] id 5 len 10

*Mar  1 00:35:47.987: Se1/0 LCP:    MagicNumber 0x00315735 (0x050600315735)

*Mar  1 00:35:47.995: Se1/0 PPP: I pkt type 0xC021, datagramsize 14 link[ppp]

*Mar  1 00:35:47.995: Se1/0 PPP: I pkt type 0x8021, datagramsize 14 link[ip]

*Mar  1 00:35:47.999: Se1/0 PPP: I pkt type 0x8207, datagramsize 8 link[cdp]

*Mar  1 00:35:48.103: Se1/0 LCP: I CONFACK [ACKse

R2#nt] id 4 len 10

*Mar  1 00:35:48.103: Se1/0 LCP:    MagicNumber 0x01315759 (0x050601315759)

*Mar  1 00:35:48.103: Se1/0 LCP: State is Open

*Mar  1 00:35:48.107: Se1/0 PPP: Phase is FORWARDING, Attempting Forward

*Mar  1 00:35:48.107: Se1/0 PPP: Discarded CDPCP code[1] id[1]

*Mar  1 00:35:48.107: Se1/0 PPP: Queue IPCP code[1] id[1]

*Mar  1 00:35:48.119: Se1/0 PPP: Phase is ESTABLISHING, Finish LCP

*Mar  1 00:35:48.123: Se1/0 PPP: Phase is UP

*Mar  1 00:35:48.123: Se1/0 IPCP: O CONFREQ [Closed] id 1 len 10

*Mar  1 00:35:48.123: Se1/0 IPCP:    Address 0.0.0.0 (0x030600000000)

*Mar  1 00:35:48.127: Se1/0 CDPCP: O CONFREQ [Closed] id 1 len 4

*Mar  1 00:35:48.127: Se1/0 PPP: Process pending ncp packets

*Mar  1 00:35:48.127: Se1/0 IPCP: Redirect packet to Se1/0

*Mar  1 00:35:48.127: Se1/0 IPCP: I CONFREQ [REQsent] id 1 len 10

*Mar  1 00:35:48.131: Se1/0 IPCP:    Address 10.1.1.1 (0x03060A010101)

*Mar  1 00:35:48.131: Se1/0 IPCP: O CONFACK [REQsent] id 1 len 10

*Mar  1 00:35:4

R2#8.131: Se1/0 IPCP:    Address 10.1.1.1 (0x03060A010101)

*Mar  1 00:35:48.135: Se1/0 IPCP: Remove route to 10.1.1.1

*Mar  1 00:35:48.211: Se1/0 PPP: I pkt type 0x8021, datagramsize 14 link[ip]

*Mar  1 00:35:48.211: Se1/0 PPP: I pkt type 0x8207, datagramsize 8 link[cdp]

*Mar  1 00:35:48.211: Se1/0 IPCP: I CONFNAK [ACKsent] id 1 len 10

*Mar  1 00:35:48.215: Se1/0 IPCP:    Address 10.1.1.3 (0x03060A010103)

*Mar  1 00:35:48.215: Se1/0 IPCP: O CONFREQ [ACKsent] id 2 len 10

*Mar  1 00:35:48.215: Se1/0 IPCP:    Address 10.1.1.3 (0x03060A010103)

*Mar  1 00:35:48.219: Se1/0 CDPCP: I CONFACK [REQsent] id 1 len 4

*Mar  1 00:35:48.227: Se1/0 PPP: I pkt type 0x8021, datagramsize 14 link[ip]

*Mar  1 00:35:48.227: Se1/0 IPCP: I CONFACK [ACKsent] id 2 len 10

*Mar  1 00:35:48.227: Se1/0 IPCP:    Address 10.1.1.3 (0x03060A010103)

*Mar  1 00:35:48.227: Se1/0 IPCP: State is Open

*Mar  1 00:35:48.227: Se1/0 IPCP: Install negotiated IP interface address 10.1.1.3

*Mar  1 00:35:48.243: Se1/0 IPC

R2#P: Install route to 10.1.1.1

*Mar  1 00:35:50.095: Se1/0 PPP: I pkt type 0x8207, datagramsize 8 link[cdp]

*Mar  1 00:35:50.095: Se1/0 CDPCP: I CONFREQ [ACKrcvd] id 2 len 4

*Mar  1 00:35:50.099: Se1/0 CDPCP: O CONFACK [ACKrcvd] id 2 len 4

*Mar  1 00:35:50.099: Se1/0 CDPCP: State is Open

R2#

 

R2#show ip int bri | exclu unassi

Interface                  IP-Address      OK? Method Status                Protocol

Serial1/0                  10.1.1.3        YES IPCP   up                    up

R2#

R2#ping 10.1.1.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/28/104 ms

R2#ping 10.1.1.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/26/60 ms

R2#

 

Now, let me try configuring the IP address using DHCP:

 

R1(config)#ip dhcp pool TEST

R1(dhcp-config)#network 10.1.1.0 /24

R1(dhcp-config)#default-router 10.1.1.1

R1(dhcp-config)#exit

R1(config)#ip dhcp excluded-address 10.1.1.1

R1(config)#ip dhcp excluded-address 10.1.1.255

R1(config)#

 

R1(config-if)#peer default ip address dhcp-pool TEST

 

R1#debug ip dhcp server packet

DHCP server packet debugging is on.

R1#debug ip dhcp server eve

R1#debug ip dhcp server events

DHCP server event debugging is on.

R1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#int ser1/0

R1(config-if)#shut

R1(config-if)#

*Mar  1 00:45:37.039: %LINK-5-CHANGED: Interface Serial1/0, changed state to administratively down

*Mar  1 00:45:38.039: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down

R1(config-if)#no shut

R1(config-if)#no shut

*Mar  1 00:46:01.987: DHCPD: checking for expired leases.

R1(config-if)#no shut

R1(config-if)#

*Mar  1 00:46:12.179: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up

R1(config-if)#

*Mar  1 00:46:12.435: DHCPD: allocate request for client cisco-10.1.1.1-Serial1/0 on Serial1/0.

*Mar  1 00:46:12.435: DHCPD: Pool TEST specified.

*Mar  1 00:46:12.435: DHCPD: Interface Serial1/0 is not associated with any VRF.

*Mar  1 00:46:12.439: DHCPD: found pool TEST for client cisco-10.1.1.1-Serial1/0.

*Mar  1 00:46:12.439: DHCPD: Allocate an address without class information (10.1.1.0)

R1(config-if)#

*Mar  1 00:46:13.307: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

R1(config-if)#

*Mar  1 00:46:14.439: DHCPD: Adding binding to radix tree (10.1.1.2)

*Mar  1 00:46:14.439: DHCPD: Adding binding to hash tree

*Mar  1 00:46:14.439: DHCPD: assigned IP address 10.1.1.2 to client 6369.7363.6f2d.3130.2e31.2e31.2e31.2d53.6572.6961.6c31.2f30.

R1(config-if)#

 

R2#ping 10.1.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/128 ms

R2#ping 10.1.1.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/56 ms

R2#

No comments:

Post a Comment