OSPF Areas: NSSA (Not So Stubby Area):
· NSSA is a Stub area, which has external connectivity.
· But, we just learnt in the previous posts, that External routes are not allowed inside a Stub area, so how do we handle the situation?
· The Answer is, Type 7 LSA (NSSA LSA)
· But, these LSAs are not allowed outside NSSA area, so ABR will convert them as LSA Type 5 before sending them to the other areas.
Network topology and Configs are same as the previous post (Stub Area).
· In the previous Stub Area post, we have observed that, after configuring Area 1 as Stub area, External LSAs were blocked by an ABR to enter the Stub Area.
· But we still observed Inter-area routes. (Summary LSAs were still allowed)
Now let’s configure Area 1 as NSSA:
R2(config-router)#do show run | i stub
area 1 stub no-summary
R2(config-router)#no area 1 stub no-summary
R2(config-router)#no area 1 stub
R2(config-router)#area 1
*Jun 15 14:57:50.179: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
R2(config-router)#area 1 nssa
R2(config-router)#
*Jun 15 14:57:55.187: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/1 from DOWN to DOWN, Neighbor Down: Adjacency forced to reset
R2(config-router)#
*Jun 15 14:58:19.587: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/1 from LOADING to FULL, Loading Done
R2(config-router)#
R3(config)#router ospf 1
R3(config-router)#no area 1 stub
*Jun 15 14:58:13.235: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
R3(config-router)#area 1 nssa
R3(config-router)#
*Jun 15 14:58:15.283: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/1 from DOWN to DOWN, Neighbor Down: Adjacency forced to reset
R3(config-router)#
*Jun 15 14:58:19.627: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/1 from LOADING to FULL, Loading Done
R3(config-router)#
Creating 2 loopbacks on R3 and redistributing into OSPF:
R3(config-router)#int loop33
R3(config-if)#ip add
R3(config-if)#ip address 33.33.33
*Jun 15 14:59:52.543: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback33, changed state to up
R3(config-if)#ip address 33.33.33.33 255.255.255.255
R3(config-if)#int loop 133
R3(config-if)#ip add
R3(config-if)#ip address 133.1
*Jun 15 15:00:07.843: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback133, changed state to up
R3(config-if)#ip address 133.133.133.133 255.255.255.255
R3(config-if)#route-map LOOPBACKS
R3(config-route-map)#match interface loop33
R3(config-route-map)#match interface loop133
R3(config-route-map)#router ospf 1
R3(config-router)#redistribute connected route-map LOOPBACKS subnets
R3(config-router)#
Now, let’s check the Routing tables:
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/129] via 20.1.1.2, 00:01:41, Serial1/1
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 20.1.1.2, 00:01:41, Serial1/1
33.0.0.0/32 is subnetted, 1 subnets
C 33.33.33.33 is directly connected, Loopback33
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Serial1/1
22.0.0.0/32 is subnetted, 1 subnets
O 22.22.22.22 [110/65] via 20.1.1.2, 00:01:41, Serial1/1
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.1.1.0 [110/128] via 20.1.1.2, 00:01:42, Serial1/1
133.133.0.0/32 is subnetted, 1 subnets
C 133.133.133.133 is directly connected, Loopback133
R3#
Observations:
· Only External routes are blocked (Inter-area routes are still allowed)
· There is no default route generated by ABR; if we configure NSSA, ABR will not generate default route into NSSA by default.
· It was happening by default in Stub area.
· We have newly created loopbacks as connected.
· These newly created loopbacks on R3 are redistributed into OSPF on R3.
· So R2 should see these routes as TYPE 7 LSAs.
· And R1 should see these routes as Type 5 LSAs, as R2 is converting them from Type-7 to Type-5 while sending them to R1.
· Let’s check this one
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 10.1.1.1, 00:11:18, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
33.0.0.0/32 is subnetted, 1 subnets
O N2 33.33.33.33 [110/20] via 20.1.1.3, 00:08:07, Serial1/1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 20.1.1.3, 00:08:07, Serial1/1
20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Serial1/1
22.0.0.0/32 is subnetted, 1 subnets
C 22.22.22.22 is directly connected, Loopback22
111.0.0.0/32 is subnetted, 1 subnets
O E2 111.111.111.111 [110/20] via 10.1.1.1, 00:08:08, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial1/0
11.0.0.0/32 is subnetted, 1 subnets
O E2 11.11.11.11 [110/20] via 10.1.1.1, 00:08:08, Serial1/0
133.133.0.0/32 is subnetted, 1 subnets
O N2 133.133.133.133 [110/20] via 20.1.1.3, 00:08:08, Serial1/1
R2#
*** R3’s loopbacks 33.33.33.33 and 133.133.133.133 are appearing as O N2 routes.
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 10.1.1.2, 00:14:10, Serial1/0
33.0.0.0/32 is subnetted, 1 subnets
O E2 33.33.33.33 [110/20] via 10.1.1.2, 00:10:59, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/129] via 10.1.1.2, 00:13:46, Serial1/0
20.0.0.0/24 is subnetted, 1 subnets
O IA 20.1.1.0 [110/128] via 10.1.1.2, 00:14:10, Serial1/0
22.0.0.0/32 is subnetted, 1 subnets
O IA 22.22.22.22 [110/65] via 10.1.1.2, 00:14:10, Serial1/0
111.0.0.0/32 is subnetted, 1 subnets
C 111.111.111.111 is directly connected, Loopback111
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial1/0
11.0.0.0/32 is subnetted, 1 subnets
C 11.11.11.11 is directly connected, Loopback11
133.133.0.0/32 is subnetted, 1 subnets
O E2 133.133.133.133 [110/20] via 10.1.1.2, 00:11:00, Serial1/0
R1#
*** R3’s loopbacks 33.33.33.33 and 133.133.133.133 are appearing as O E2 routes as ABR R2 is converting them from Type-7 to Type-5.
We will learn about Totally NSSA in the next post à
No comments:
Post a Comment