OSPF Areas: Stub Area
· Stub areas are areas, into which external LSAs are not flooded.
· ABR will inject a default-route into this area.
Let’s take a small scenario to understand this:
· R1: Ser1/0 and R2: Ser1/0 are part of Area 0
· R2: Ser1/1 and R3 Ser1/1 are part of Area 1
Let us see the configs, before configuring Stub Area:
OSPF Configuration on R1:
R1#show run | begin router ospf 1
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
redistribute connected subnets route-map REDISTRIBUTE-LOOP àR1 is acting as ASBR
network 1.1.1.1 0.0.0.0 area 0
network 10.1.1.1 0.0.0.0 area 0
!
!
route-map REDISTRIBUTE-LOOP permit 10
match interface Loopback11 Loopback111
!
R1#show run int loop11
Building configuration...
Current configuration : 68 bytes
!
interface Loopback11
ip address 11.11.11.11 255.255.255.255
end
R1#show run int loop111
Building configuration...
Current configuration : 73 bytes
!
interface Loopback111
ip address 111.111.111.111 255.255.255.255
end
R1#
R2#show run | begin router ospf 1
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.2 0.0.0.0 area 0
network 20.1.1.2 0.0.0.0 area 1
!
** R2 is acting as an ABR, which interconnects Area 0 and Area 1
R3#show run | begin router ospf 1
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 1
network 20.1.1.3 0.0.0.0 area 1
!
Let us see the IP Routing Table on the Routers:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 10.1.1.2, 00:07:28, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/129] via 10.1.1.2, 00:07:28, Serial1/0
20.0.0.0/24 is subnetted, 1 subnets
O IA 20.1.1.0 [110/128] via 10.1.1.2, 00:07:28, Serial1/0
111.0.0.0/32 is subnetted, 1 subnets
C 111.111.111.111 is directly connected, Loopback111
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial1/0
11.0.0.0/32 is subnetted, 1 subnets
C 11.11.11.11 is directly connected, Loopback11
R1#
Observations:
· R1 is learning about R2’s loopback 2.2.2.2 through OSPF
· R1 is learning about R3’s loopback 3.3.3.3 through OSPF
· R1 is also learning about R2-R3 connected serial link 20.1.1.0/24 through OSPF
· R1 is learning about R2’s loopback as intra-area route (LSA Type 1, Router LSA, hence the route is showing up as O route in the Routing Table.
· R1 is learning about R3’s loopback and the connected link between R2 and R3 as Inter-area routes (LSA Type-3, Summary LSA), hence these routes are showing up as O IA routes in the Routing table.
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 10.1.1.1, 00:07:49, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 20.1.1.3, 00:11:16, Serial1/1
20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Serial1/1
111.0.0.0/32 is subnetted, 1 subnets
O E2 111.111.111.111 [110/20] via 10.1.1.1, 00:07:49, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial1/0
11.0.0.0/32 is subnetted, 1 subnets
O E2 11.11.11.11 [110/20] via 10.1.1.1, 00:07:50, Serial1/0
R2#
Observations:
· R2 is learning R1’s loopback 1.1.1.1 through OSPF
· R2 is learning R3’s loopback 3.3.3.3 through OSPF
· R2 is also learning about Redistributed routes from R1 (11.11.11.11 and 111.111.111.111) through OSPF
· R2 is learning about R1’s and R3’s loopbacks as intra-area routes (LSA Type 1, Router LSA), hence these routes are showing up as O routes in the Routing Table.
· R2 is learning Redistributed from R1 as External routes (LSA Type 5, External LSA, hence these routes are showing up as O E2 routes in the Routing table.
· ** I’ll post a section on E1 and E2 routes later
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/129] via 20.1.1.2, 00:11:32, Serial1/1
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 20.1.1.2, 00:11:32, Serial1/1
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Serial1/1
111.0.0.0/32 is subnetted, 1 subnets
O E2 111.111.111.111 [110/20] via 20.1.1.2, 00:08:00, Serial1/1
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.1.1.0 [110/128] via 20.1.1.2, 00:11:32, Serial1/1
11.0.0.0/32 is subnetted, 1 subnets
O E2 11.11.11.11 [110/20] via 20.1.1.2, 00:08:00, Serial1/1
R3#
Observations:
· R3 is learning about R1’s loopback 1.1.1.1 through OSPF
· R3 is learning about R2’s loopback 2.2.2.2 through OSPF
· R3 is learning about R2-R1 connected serial link 10.1.1.0/24 through OSPF
· R3 is also learning about Redistributed routes from R1 (11.11.11.11 and 111.111.111.111) through OSPF
· R3 is learning about R1’s loopback, R2’s loopback and the connected link between R2-R1 as Inter-are routes (LSA Type-3, Summary LSA), hence these routes are showing up as O IA routes in the Routing table.
· R2 is learning Redistributed from R1 as External routes (LSA Type 5, External LSA, hence these routes are showing up as O E2 routes in the Routing table.
Let us see the configs, after configuring Stub Area:
· After configuring Area 2 as Stub area, we should not see External routes in R3’s Routing Table.
· Let us check that
R2(config)#router ospf 1
R2(config-router)#area 1 stub
R2(config-router)#
*Jun 15 13:36:25.699: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
R2(config-router)#
*Jun 15 13:36:39.587: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/1 from LOADING to FULL, Loading Done
R2(config-router)#
R3(config)#router ospf 1
R3(config-router)#area 1 stub
R3(config-router)#
*Jun 15 13:36:34.443: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
R3(config-router)#
*Jun 15 13:36:39.631: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/1 from LOADING to FULL, Loading Done
R3(config-router)#
Now, we will see the routing table of R3:
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 20.1.1.2 to network 0.0.0.0
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/129] via 20.1.1.2, 00:01:50, Serial1/1
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 20.1.1.2, 00:01:50, Serial1/1
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Serial1/1
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.1.1.0 [110/128] via 20.1.1.2, 00:01:50, Serial1/1
O*IA 0.0.0.0/0 [110/65] via 20.1.1.2, 00:01:50, Serial1/1
R3#
Observations:
· Fantastic, External routes are disappeared from R3’s Routing table!!!
· That means ABR R2 is blocking all Type-5 Externals LSAs from entering the Stub Area.
· Also, we see a default route injected by ABR R2 into the Stub area.
We shouldn’t see any change in R2’s and R1’s Routing table, let us check that:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 10.1.1.2, 00:35:21, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/129] via 10.1.1.2, 00:05:10, Serial1/0
20.0.0.0/24 is subnetted, 1 subnets
O IA 20.1.1.0 [110/128] via 10.1.1.2, 00:35:21, Serial1/0
111.0.0.0/32 is subnetted, 1 subnets
C 111.111.111.111 is directly connected, Loopback111
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial1/0
11.0.0.0/32 is subnetted, 1 subnets
C 11.11.11.11 is directly connected, Loopback11
R1#
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 10.1.1.1, 00:05:17, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 20.1.1.3, 00:05:02, Serial1/1
20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Serial1/1
111.0.0.0/32 is subnetted, 1 subnets
O E2 111.111.111.111 [110/20] via 10.1.1.1, 00:05:02, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial1/0
11.0.0.0/32 is subnetted, 1 subnets
O E2 11.11.11.11 [110/20] via 10.1.1.1, 00:05:03, Serial1/0
R2#
***No change in R1 and R2 Routing tables.
We will learn about Totally stubby area in the next post-à
No comments:
Post a Comment